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Acronyms and Abbreviations 
App Application (software program) 
CRS Coordinate Reference System 

ECW Enhanced Compression Wavelet 

EPSG European Petroleum Survey Group 
ESWADE Eswatini Water and Agriculture Development Enterprise 

EU European Union 

FAO Food and Agriculture Organisation (of the United Nations) 
GIS Geographic Information System 

GOE Government of (the Kingdom of) Eswatini 

GPS Global Positioning System 

IT Information Technology 

LIMS Land Information Management System 

LMB Land Management Board 
LUP Land Use Planning 

MEPD Ministry of Economic Planning and Development 

ODBC Open Data Base Connectivity 
ODK Open Data Kit 

SGD Surveyor General's Department 

SLAM Sustainable Land Administration and Management 
SNL emaSwati Nation Land (formerly Swazi Nation Land) 

TA Technical Assistance 

TDL Title Deed Land 
Tinkhundla Electoral and administrative areas; a division of regions, 

similar to ‘districts. 

TOR Terms of Reference 
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1 Introduction 

This user guide on the SLAM Landholding Information Management System (LIMS) is a one-

source technical reference for the system that collects, stores, edits, delivers and maintains 

information about homestead landholdings on emaSwati Nation Land (SNL). 

The LIMS is a product of the Sustainable Land Administration and Management (SLAM) 

project that operated, as a pilot, between October 2016 and May 2019. The key stakeholders 

in the SLAM project include: 

› Ministry of Natural Resources and Energy / Surveyor General’s Department (SGD) 

› Ministry of Agriculture / Land Use Planning Department & Eswatini Water and Agriculture 

Development Enterprise (ESWADE) 

› Ministry of Tinkhundla Administration and Development 

› Pilot area chiefdoms 

› Hhohho / Ndzingeni 

› Ludlawini 

› Nkamanzi 

› Ndzingeni 

› Mvuma 

› Lubombo / Dvokodvweni 

› Malindza 

› Mdumezulu 

› Manzini / Mkhiweni 

› Dvokolwako 

› Mbelebeleni 

› Ekutsimuleni 

› Shiselweni / Sandleni 

› Ngololweni 

› Nkhungwini 

› Kanzameya 

› Nkalaneni 

› Gasa 

› Lomfa 

› Delegation of the European Union in Eswatini 

› Ministry of Economic Planning and Development / Aid Coordination Management Section 

› COWI A/S (technical assistance advisers) 

The LIMS is largely managed, operated and maintained in the Surveyor General’s 

Department (SGD) in Mbabane. 
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1.1 Landholding Information Management System 
Overview 

The architecture for the land information management system (LIMS) consists of the 

following main components: mobile devices with a data collection app, a server receiving and 

storing the collected information, and office equipment to check, handle and visualise the 

collected data. 

The use of mobile devices and technologies for collection of (geo) information in the field has 

grown popular in the last decade, avoiding the use of pen and paper-based surveys. The 

challenges associated with these paper-based methodologies, such as transcription errors in 

data entry from handwritten forms, lost forms, linking copies of supporting documents to the 

appropriate record are non-existent in a digital approach, and a full audit trail from data 

capture in the field, quality control in the office, to record completion can be achieved. 

server

mobile devices

field teams

office field

Internet / WiFi

field
collected

data

office team

document 
management

(web) application

(geo) database

 
Figure 1: SLAM LIMS architecture 

An evaluation of various alternatives for system components was made before the choice of 

specific software tools. Limiting factors in the decision-making process included the project 

budget, technical assistance input, existing capacity, and short- and medium-term 

sustainability. A SLAM LIMS website (cloud access) is envisaged but has not yet been 

implemented. 

1.1.1 Field Data Collection App  

The data collection app can record geographical information, e.g. geometries such as points 

of interest, roads, parcels, fields as well as alphanumerical attributes describing these 

geometries. The data collection app can guide field teams in performing structured and 

predefined digital questionnaires, and even facilitates the recording and storing photos, 

videos, barcodes, audio. 



 

Introduction / Landholding Information Management System Overview 

     

SLAM LIMS USER GUIDE   4  

The data collection app is able to work offline under conditions where internet connectivity 

and speed are limited and unstable. The mobile devices will have supporting offline spatial 

data available, such as world imagery, other ortho(aerial) photos, supporting vector 

information, such as downloaded open street map data. 

The GeoODK Collect1 app was selected as data collection application on the mobile devices 

for the SLAM project. GeoODK is suitable for and android operating system and is based on 

the open source Open Data Kit (ODK Collect2) software with added spatial/geographic 

functionality. 

 

Figure 2: impression of GeoODK Collect 

1.1.2 Office Processing 

The server holds the definition of the desired information (i.e. a data model of attributes, 

geometries, and questionnaires) captured in a “form”3 which can be loaded and used on the 

mobile device. The collected data will be synchronised between mobile device and server via 

Internet or Wi-Fi connection and stored in a geodatabase with all collected information.  

The server facilitates further handling, supervises quality control, analysis and completion of 

the collected information by the office team, as well as sharing and visualisation of the 

results with stakeholders (chiefdom landholding data on chiefdom laptops). 

                                                
1 https://play.google.com/store/apps/details?id=com.geoodk.collect.android  
2 https://docs.opendatakit.org/collect-intro/  
3 Landholding & Land Use Data Form, version F: d.d. 13-08-2018 

https://play.google.com/store/apps/details?id=com.geoodk.collect.android
https://docs.opendatakit.org/collect-intro/
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A Dell PowerEdge R730 rackserver has been deployed with MS Windows 2012 R2 operating 

system and a PostgreSQL database. The server operates in a small local area network (LAN). 

The server has a 250GB SSD and should have two hot-swap 1TB hard disk drives but 

problems with procurement means that only one 1TB external drive provides the data 

storage. The network is not connected to the Internet, nor to the government computer 

network. 

Office Equipment that is available to perform quality control, updates, visualisation is 

available: 

› Desktop computers with Geographic Information System (GIS) software for data editing, 

querying and viewing spatial and textual data; QGIS4 geographic information system 

(GIS) software.  

› Office productivity tools for data distribution and dissemination; MS Office. 

› A0 map plotters and A4 printers. 

GIS desktop software is QGIS (version 2.18 and 3.4), which has robust links and 

compatibility with server-based PostGIS databases. 

Microsoft Office Word and Excel software with ODBC links to the PostGIS database are used 

for preparing and printing registers and lists. 

1.2 Data Structure 

Both attribute and spatial data are stored within LIMS’s 

central PostgreSQL odk_prod database. Daily backups 

of the odk_prod database are made using Windows 

Server’s TaskScheduler (see Appendix D). Data are 

distributed across numerous related database tables. 

The tables and views (or ‘snapshots’) of one or more 

tables are made available in QGIS as layers. 

The data in LIMS comprises of the following 

information stored in its geo-database or as files on 

the server: 

› Editable layers/tables 

› Homestead (points) 

› Landholdings / fields (polygons) 

› Land borrowed in/out (polygons) 

› Community features (points and polygons) 

› Quality Control layers/tables 

› Checks on overlaps 

› Original collected ODK/GPS data 

› Administrative boundaries 

› Cadastral areas 

› Regions, tinkhundla and chiefdoms 

                                                
4 https://www.qgis.org 

Figure 3: QGIS LIMS data layers and views 

https://www.qgis.org/
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› Raster image files (orthophoto maps) 

› Images in ECW format 

› A grid visualising location of image files 

1.3 Coordinate Reference Systems 

A coordinate reference system (CRS) is a combination of: 

› Geographic position (datum) 

› Map projection 

A geographic location is defined by a geodetic datum (e.g. Cape datum) and latitude and 

longitude east or west of the Greenwich meridian. A map projection is defined by parameters 

for the shape of the earth (major axis, minor axis, e.g. Lo31). A coordinate reference system 

is a combination of a datum and map projection. 

This user guide discusses coordinates reference systems in the context of the SLAM LIMS 

software environment; it does not cover the subject generally. A brief overview of coordinate 

reference systems in QGIS is provided here; more information can be found in any technical 

text on the subject5 and in the QGIS user manual. 

When starting QGIS with a new empty project, the default CRS will be EPSG:4326, where 

EPSG means 'European Petroleum Survey Group'6 and '4326' is the code for a the WGS84 

CRS.  

When starting any new task in QGIS, the QGIS program is started (not an existing project 

file with the extension .qzs) and usually QGIS will start with Recent Projects window. For a 

new task, create a new QGIS project. 

For SLAM data, QGIS can be set up with the right environment that defines the coordinate 

reference system, layers and layer styles. This environment is set using a plugin, which is a 

software extension to QGIS. To load QGIS plugins, see Appendix C0. 

The SLAM environment plugin           configures QGIS with the appropriate coordinate 

reference systems. Three coordinate reference systems are loaded by the SLAM 

environment. 

› EPSG: 4326 – this is WGS84 datum and no projection i.e. geographical coordinates. 

› EPSG: 32736 – this is WGS84 datum and UTM zone 36S projection. 

› ESSG: 22291 – this is Cape datum and Lo31 projection. 

The table below lists these, and other relevant CRS codes used in the SLAM LIMS. 

                                                

5 https://en.wikibooks.org/wiki/Coordinate_Reference_Systems_and_Positioning  

6 www.epsg.org  

https://en.wikibooks.org/wiki/Coordinate_Reference_Systems_and_Positioning
http://www.epsg.org/
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Code Description / Coordinate Reference System (CRS) 

Standard 

EPSG:3857

  

WGS84 ellipsoid, pseudo Mercator projection (used by Google maps, 

OpenStreetMap, Bing, etc.) 

EPSG:4326 WGS84 ellipsoid, no projection – geographical coordinates (latitude / 

longitude) 

EPSG:22291 Cape datum, Clarke 1880 ellipsoid, Lo (zone 31) projection (based on 

a generic 5-point transformation, with accuracy of 9-15m) 

EPSG:32736 WGS84 datum/ellipsoid, UTM projection zone 36S 

User defined 

USER100001 Cape datum, Clarke 1880 ellipsoid, Lo (zone 31) projection. This CRS 

is based on SGD geodetic data and is very close to but not exactly the 

same as EPSG:22291. However, for most practical purposes in SLAM, 

either USER10001 or EPSG:22291 may be used. 

By default, QGIS starts with the default CRS (EPSG:4326), and it automatically changes to 

the CRS of the first vector or raster data set layer added to a new project. 

If the SLAM edit environment is loaded the default CRS will also be EPSG:4326 and all the 

SLAM data layers will be presented in this CRS. Adding a raster (image) layer may result in a 

CRS inconsistency if the image file is not in EPSG:4326. However, in most cases, but not all, 

QGIS will recognise the CRS of the image file and automatically apply an “on-the-fly” 

reprojection. Where the image file does not include CRS metadata that QGIS recognises, the 

image will appear in the wrong location. It can be ‘brought’ back into consistency with SLAM 

data by manually setting the projection. 

› Right-click on the image layer > Properties > Source 

Set the source coordinate reference system to EPSG: 22291- Cape/Lo31. If the image file 

has the CRS EPSG: 102478 – Cape_Lo31, this is wrong. Change it to EPSG: 22291. 

Although EPSG: 22291 Cape datum Lo projection zone 31 is the official CRS for Eswatini, 

QGS works by default in EPSG: 4326 and re-projects automatically all other data into this 

default CRS. Furthermore, spatial data captured in the field is also in EPSG: 4326.  
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Figure 4: QGIS raster layer CRS properties 

Refer to the QGIS manual for more on projections and transformations. 

If a data set is used without a CRS or a standard conversion is available, it may be necessary 

to ‘georeference’ the image to bring it into the project CRS. Refer to Appendix E for more 

information about georeferencing. 

1.4 Orthophoto Image Files 

The image files, or orthophoto map files, used 

as a backdrop for homestead landholding data 

are provided by the SGD. These ‘ortho-

rectified’ images, which means they are 

distortion free and scale accurate, have a 

ground resolution of 0.25 metres (pixel size). 

The image files are arranged in a grid of map 

tiles 8km by 4km. The CRS for these raster 

image files is EPSG: 22291 – Cape/Lo31. 

However, some may have a ‘user-defined’ CRS 

which for all mapping purposes is the same as 

EPSG: 22291. 

The map tile or sheet is identified by a letter 

and number, starting with A01 in the top left 

and ending S31 in the bottom right. Note that 

the “grid” layer is available in QGIS to provide 

an overview of these map tiles. 

The files are stored in a directory in the fileserver at: 
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> D SLAM EXDR02 Geodata (\\192.168.8.2) [mapped drive letter]\Geodata\Imagery\ECW_SGD_2015 

The file formats are Enhanced Compression Wavelet (ECW) that is supported directly by 

QGIS.  

For performance reasons: Do not use the files directly from the above directory on 

the fileserver. Copy the files needed to the local computer. 

The format is not supported by GeoODK for use in data collection, so the format must be 

converted to MBTiles for use on the tablet computer in GeoODK. 

MBTiles is a raster file format. The files are compressed and hold geographic location and 

projection information. The format is specifically designed for use in web or mobile 

applications. MBTiles is an open source specification and based on SQLite. Refer to Appendix 

B about how to create MBTiles. 

1.5 Attribute Data 

Attribute or text data is collected in the field by a questionnaire form. There are a series of 

questions, and sub-questions that depend on answers given. 

 

Figure 5: Field data collection form structure and flow 

  

Enumerator
Date of enumeration
Landholding unit number

Region
Inkhundla (~district)

Pop. census EA nr.

geometry: Homestead location

Respondent
Is head of homestead?
Do you know SLAM?

Name Homestead Head
 (if respondent ≠ homestead head)
Identification Number
Birthdate
Gender
Marital Status
# Spouses

Loop: 
Name of Spouse(s)
Status of Spouse

# of owned/held fields

Provide other information
Take a photo (not used)

# of fields borrowed in / rented in # of fields borrowed in / rented in

Loop:  owned field(s) to be captured

geometry:

Land acquisition list
Year
Names involved
Description

geometry: Owned fields/area

Loop:  borrowed field(s) to be captured

geometry:

Borrowed from
Description

geometry: Borrowed fields/area

Loop:  fields lent out to be captured

geometry:

Lent to
Description

geometry: Lent out fields/area
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The form collects the following attribute data items: 

Homestead landholding id; region; district; chiefdom; landholdings id; land use; allocation year; 

population census number; homestead head name; homestead head id; homestead head birthdate; 

homestead head gender; homestead head alive/deceased; homestead head marital status; number 

of spouses;  spouse names; chiefdom disputes; other disputes; type land dispute; year dispute start; 

land dispute status; other relevant information; enumeration date; number parcels; amount land 

rented in; amount land rented out; area land holdings; area land rented in; area land rented out. 

The data are held in a 4 core linked tables: 

 
Figure 6: Attribute database tables 

1.6 Key Fields 

Each of the tables shown in Figure 6 above are linked by a key field. These key fields may be 

arbitrary with only the purpose of providing linkages but in may also be an important 

identifier of a land object. The SLAM database uses three key geospatial object identifiers: 

› Homestead_id 

› Landholding_id 

› Landholdings_id 

The homestead_id is a unique number for all homestead point records (the location of the 

homestead houses) in the range 1-n for all chiefdoms where n is the last homestead record 

in the table for all homesteads in the Kingdom. During data collection, homesteads are 

labelled with homestead_id, which is a system generated sequence identification number, 

unique within the whole database, assigned in the order of the homesteads records arriving 

from the field and being loaded into the server. 

The landholding_id is a unique number for all homestead polygon records in the range 1-n 

for all chiefdoms where n is the last landholding record in the table for all landholdings in the 

Landholding 
(when acquired; 

from where)

Homestead
(chiefdom 

affilliation; head; 
spouse)

Land borrowed
(from who)

Land lent out 
(to who; 

conditions)
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Kingdom. Note that two polygons may have the same landholding_id if they are landholdings 

belonging to the same homestead. Landholding polygons may be uniquely identified by their 

homestead_id plus an ordinal number in the form 1234_1 for field 1 and 1234_2 for field 2 

both belonging to the same homestead. 

The landholdings_id is a unique identifier only in each chiefdom in the range of 1-n where n 

is the last landholding in a particular chiefdom; i.e. the number is not unique and is 

duplicated in each chiefdom. The purpose of the landholdings_id is to provide an easy to use 

identifier for chiefdom landholding records, registers and maps. 

Two examples are shown below. Figure 7 shows homestead_id and landholding_id, both 

unique for the whole Kingdom. Figure 8 shows landholdings_ids which are unique only in a 

chiefdom for both the homestead and homestead landholdings. 

 
Figure 7: Homestead_id and landholding_id 

 
Figure 8: Landholdings_id for both homestead and land (fields) 
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2 Data Collection 

Landholding data are collected or captured in the field using tablet computers. This section of 

the LIMS user guide explains how to collect data using a tablet computer. 

For instructions on setting up a tablet computer and troubleshooting problems with the tablet 

computer, data collection and data transfer issues, refer to Appendix A.1. 

2.1 GeoODK – Field Data Collection App 

The software used for landholding data collection is called GeoODK Collect. The GeoODK user 

interface may start with the main menu: 

 

Figure 9: GeoODK main menu 

The main screen icons are described below… 

 

Form to collect data about the landholder etc. 

 

Send collected data from the tablet to the office fileserver database. 

 

Edit collected data. 

 

Select and show orthophoto maps and collected polygon data. 

 

Delete data (do not use except when tablet memory is full). 

 

Setting (not normally used). 
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2.2 Collect Field Data 

To start collecting data at a homestead: 

› Tap the [Collect Data] icon. ¨ 

› This will provide a list of forms. In most cases select the Landholding and Land Use Data 

Form. 

 

You are now ready to start data collection. 

› The Landholding and Land Use Data Form contains multiple pages. To move from the 

first page to the second, swipe right to left… 

 

The first page is for the date. The default is today’s date. 

 

› Next select the enumerator (name of person doing the interview to collect data) and 

chose your name.  
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If your name is not listed, select [Other] and type it in. Type it in carefully and use your 

name with exactly the same spelling for each form. 

 

› Again, swipe left to go to the next page, which is the Enumerator sequence. 

 

The enumerator sequence for each day usually always starts at [1]. 

› Next select the region in which data are being collected. 

 

› Then select the inkhundla.  

Note that only the tinkhundla in your chosen region are listed. 
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› Swipe left to reveal the page to enter the population census number.  

This is usually written on a sticker above the homestead door. 

 

› Then tap the [Record Location] bar that will capture a position coordinate of where you 

are standing, which is should be next to / in front of the homestead dwelling. 
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Your location is then shown on the orthophoto. The blue circle represents the region of 

positional uncertainty, which depends on the GPS satellite signal. You can also manually 

select a point on the orthophoto to be captured as the homestead location. 

In the top of the orthophoto are two (faint) icons.  

› Select  to identify and centre your location in the orthophoto.  

› Select  to save your current geographical position in the form.  

2.3 Data Upload 

Uploading the collected field data is done in the office when the tablet is connected via Wi-Fi 

to the server.  
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› Tap  to send data to the server. 

› Tap [Toggle All] to select all the forms to 

upload 

› Tap [Send Selected] to upload all those 

marked with; the results of the upload 

will be displayed. 

 

2.4 Delete Data 

Do not delete data immediately after upload. Keep data on the tablet. The system 

administrator will periodically delete the data on all tablets after upload has been verified at 

the server. 

2.5 Troubleshooting GeoODK Problems 

If there is a problem uploading data from the tablet to the server or the tablet runs very 

slow, refer to Appendix A.2 Troubleshooting GeoODK and Data Collection. 



 

Data Processing / Troubleshooting GeoODK Problems 

     

SLAM LIMS USER GUIDE   18  

3 Data Processing 

Data collected in the field are uploaded in the office to the SLAM database odk_prod. The 

database comprises numerous tables and those that hold the field collected data are 

identified by a suffix (odk). 

The field data are uploaded via a Wi-Fi connection (SlamDataCollection) from the tablet 

computer to the SLAM database, after which an automatic process will load the data from the 

odk to the edit tables in the database.  

 

Data are processed in the edit environment in two stages:  

› Editing of field data geometry (homestead points and field polygons) to eliminate gaps, 

overlaps, etc. and to make the features consistent with the underlying orthophoto base 

map.  

› Quality control and editing of all textual data.  
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3.1 QGIS Set Up 

Refer to Appendix C QGIS Set Up, for installing and set up of QGIS for the SLAM edit 

environment. 

Editing can be done with the whole dataset displayed in the QGIS map window. However, if 

you want to edit data within only a particular chiefdom then filters to the layers must be 

applied (see section 3.3). 

Note that data can only be edited in the SLAM edit environment. Data in the SLAM chiefdom 

environment is read only.  

3.2 Data Editing 

The layer “Homesteads QC (not changed)” is available in the Edit environment with a filter 

on field total_changes =0. This will indicate homestead (and their fields/landholdings) 

records that have not been checked/edited. Obviously, not all homestead records need 

changing after data collection, but the layer will identify areas where most homesteads have 

or have not been changed, thereby identifying areas that still need to undergo editing. 

 

Figure 10: Homestead landholding polygons not edited 

Note that after a polygon is edited, the highlighted (filled) polygons in Homesteads QC (not 

changed) layer will not clear immediately. This is because the layer is a ‘materialised view’ of 

the database, which updates every 6 hours, then clearing the highlights for edited polygons.  
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3.3  Filtering Layers 

Filters can be applied to layers to show only data from one chiefdom, highlight the layer to 

filter: 

› Layer > Filter (or right-click > filter) 

To filter (show only) records from one chiefdom in the Homestead layer 

› Scroll down the list of fields and select / double click chiefdom_list 

Note that chiefdom_list appears in the box below. Next, select the Operator, which for 

text should be [ILIKE].  

› Then, under the values box click [All] which will reveal all the chiefdom names. Double-

click to select the chiefdom (see Figure 11). 

The results will hide all homestead points not in the chiefdom of interest.  

 
Figure 11: Filter Homesteads by chiefdom 

Next, we must filter the landholdings layer. Note that this layer does not have a 

chiefdom name or chiefdom_list field. Therefore, the filter must reference a linked 

database table. The easiest way to do this is to: 

› Copy and paste the following SQL expression into the query builder window: 
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› exists (select 1 from homesteads hs where hs.id = homestead_id and chiefdom_list 

= 'chiefdomname') 

Where ‘chiefdomname’ is the name of the chiefdom. Note that the chiefdom name must 

be enclosed by quotation marks. 

› To make sure the statement is correct, click [Test], and if correct, a pop out window will 

reveal how many rows / records were returned by the SQL “where” clause. 

 
Figure 12: Filter Landholdings layer 

To filter the community_area layer by chiefdom use the following SQL statement, where 

the percentage symbol % represents any characters, which means any name or words 

contained, for example, “Mbelebeleni” will be selected / returned: 

› "community_area_name" LIKE '%Mbelebeleni%' 

For other filters and SQL queries, refer to the QGIS manual. 

3.4 Landholding Polygon Edits 

Spatial data layers available for editing include: 

› Homesteads (points) 
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› Land rented in (polygons) 

› Land rented out (polygons) 

› Landholdings (polygons) 

› Community points (points) 

› Community areas (polygons) 

The SLAM edit environment also automatically loads the (GeoODK) data collection layers as 

an aid to data editing (i.e. “Collected Data ODK/GPS”). 

3.4.1 Set Coordinate Reference System 

Before starting to edit polygons, change the QGIS coordinate reference system for the 

project from EPSG:4326 (geographical coordinates) to EPSG:22291 (grid coordinates). The 

reason for this is that QGIS performs vector data editing when used with grid coordinates 

(X,Y) rather than geographical coordinates (lat., long.). To change the project CRS: 

 
Figure 13: QGIS SLAM edit environment 

› In the bottom right corner of the QGIS window double-click on EPSG:4236, which will 

open Project Properties | CRS box, below. 

If the local CRS Cape / Lo31 does not appear in the list of Recently used coordinate 

reference systems, type 22291 into the filter for the list of coordinate reference systems. 

This will reveal Cape / Lo31 for selection.  

› Click [Apply] and [OK]. 



 

Data Processing / Landholding Polygon Edits 

     

SLAM LIMS USER GUIDE   23  

 
Figure 14: QGIS SLAM CRS 

Changing the CRS from EPSG:4326 to EPSG:22291 in QGIS will result in data appearing 

upside down.  

› To correct this, change the Rotation from 0.0o to 180.0o. 

 
Figure 15; QGIS SLAM CRS re-orientation 
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3.4.2 Edit Overview 

Usually, the first stage in data editing is to edit the landholdings polygon layer. Editing 

polygons consists of two steps: 

› Move the whole polygon to a best fit position. 

› Adjust / move / add polygon nodes and vertices to connect to adjoining polygons and to 

best fit the underlying orthophoto. 

In both cases, the guides for moving and editing polygons are: 

› The orthophoto 

› Collected data (ODK/GPS) 

Figure 16 below shows both the edit(able) polygons (green/white boundary lines) and 

collected data (black lines). The polygons are the same shape with the same gaps/overlaps 

but note the shift, which is due to difference coordinate reference systems – collected data 

(black) is WGS84 (EPSG:4326) and edit data (green) is Cape/Lo31 (EPSG:22291). 

 

Figure 16: Unedited data 

The edit task, as illustrated above, is to: 

› Move the green polygons to better fit the landholding fields as depicted in the 

orthophoto, and, 

› Move the polygon nodes and vertices for a best fit with the underlying orthophoto and 

adjoining polygons. 

Figure 17 below illustrates a final result. 
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Figure 17: QGIS edited data (green lines) with unedited data (black line) 

3.4.3 Snapping 

Before editing any data, turn on point snapping. First turn on the project snapping options: 

› Project > Snapping options 

› Click on [Topological Editing] and [Snapping on Intersection] 

 

Next, highlight the layer for editing, then: 

› Settings > Options > Digitizing > Enable snapping by default ✓ 

› Alternatively, click the snapping icon         in the snapping toolbar. 
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Figure 18: QGIS polygon in edit mode. 

In most cases a snapping tolerance of 10 pixels (approx. 2 metres on the ground) is 

appropriate. 

› Enable both the topological editing and snapping on intersection options. This will allow 

moving a vertex shared by two polygon features as if it was a single vertex.  

 
Figure 19: Move vertex with topological snap enabled 

Vertices can be added to a polygon by double-clicking on the boundary line. Do not add 

vertices unless the polygon needs to be edited to better fit the orthophoto. When adjusting a 

polygon, bear in mind rule 1 (below), that landholding allocations are usually semi-regular 

geometric shapes unless they follow a physical feature or contour. Do not add vertices on a 

straight boundary line. Examples of too many and too few vertices are shown in the figures 

below. 

3.4.4 General Rules 

Some general rules apply in making decisions about the correct geometry of polygons and 

the boundary alignments of landholdings. 

1 Landholdings, when first allocated, tend to be irregular geometric shapes, such as 

rectangles, with straight lines. But they can also follow natural features, such as a river 

or road, or the contours of a hillside. Examples are shown below. 
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 Figure 20: Typical landholding polygon geometry 

 

2 Landholding boundary lines must not cut through buildings and should not cross fields or 

cut off portions of fields. An exception to this rule is where a landholder is clearly 

encroaching into neighbouring land. 

3 Landholding boundary lines do not cross other landholding boundary lines. 

4 Landholdings do usually not cross roads. In such cases, two separate polygons are 

created on either side of the road. However, it is common to find access tracks crossing 

over landholdings. 

5 Polygons sides should follow the general alignment of a boundary feature; they should 

not 'slavishly' follow every small deviation from the general alignment; but also consider 

rule 2. 

6 Boundary features are not always clear on the orthophoto but in most cases there is 

some evidence of the boundary or corner point. Often, landholders plant trees at corner 

points and bushes along lines. 

7 Where the ortho indicates no evidence of a physical boundary line, use the field 

collected polygon as a guide. Do not reduce the size of polygons significantly in order to 

make them fit with fields and apparent boundaries on the orthophoto (see  Figure 20). 
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 Figure 21: Incorrect use of orthophoto (left) and correct use (right) based on field data capture 

3.4.5 Editing Examples 

These are some 'before and after' examples that further illustrate the general rules for 

editing landholding polygons. 

 
Figure 22: Edit example - incorrect (left), correct (right) 
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Figure 23: Edit example - incorrect (left), correct (right) 

 
Figure 24: Edit example - incorrect vertex (left), correct vertex (right) 

 
Figure 25: Edit example - incorrect (left), correct (right) aligned to orthophoto 
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3.4.6 Vertices 

Editing requires moving and snapping of one polygon corner or join (vertex) to another. To 

ensure this happens correctly, snapping mode must be set on. 

 
Figure 26: Incorrect (left) and correct (right) vertex definitions 

 
Figure 27: Edit example - incorrect (left) too few vertices, correct (right) better fit to ortho 

3.4.7 Deleting Landholding Polygons 

As a general rule do not delete polygons unless you are absolutely sure it is a double data 

collection. Check if the polygon has the same homestead attributes (homestead head and 

spouses): 

› Right-click on Homesteads layer > Open attribute table 

Compare the two homesteads for the two associated landholding polygons, for (a) the name 

and ID number of the homestead head, and (b) the name of the spouse. Note that if the 

spouse names are different and the homestead head name the same this may indicate a 

dispute rather than duplicate data collection. In this instance, and any instance where you 

are not absolutely sure that the polygons results from duplication, refer the overlapping 

landholdings back to the data collectors and the chiefdom. 



 

Data Processing / Landholding Polygon Edits 

     

SLAM LIMS USER GUIDE   31  

A landholding polygon must be deleted from the attribute table, and not the map window. 

When deleting a duplicate polygon, also delete the associated duplicate homestead point. 

Similarly, do not delete a homestead points unless you are 100% certain it is fieldwork 

duplication and not a dispute. 

3.4.8 Editing Homestead Points 

The most common edits for a homestead point are: 

› Move from outside to inside its related landholding polygon. 

› Move closer to the homestead as shown on the underlying orthophoto.  

If a homestead point falls outside a polygon, this will be reported in one of numerous quality 

control checks. 



 

Data Quality Assurance / QGIS Data Quality Control 

     

SLAM LIMS USER GUIDE   32  

4 Data Quality Assurance 

The quality control of data collection and processing is achieved by: 

› Checks applied in QGIS 

› Validation of results by chiefdom 

The QGIS checks should be performed after all the GeoODK collected data has been 

processed and edited and before any maps and lists are printed for chiefdom validation. 

4.1 QGIS Data Quality Control 

4.1.1 Check Edit Status 

First check that all the chiefdom landholdings have been edited. The edit environment will 

automatically load the layer Homestead QC (not changed) that will highlight those polygons 

not yet edited. Undertake a visual check that there are no polygons highlighted as unedited 

or unchanged. 

4.1.2 Check Overlapping Polygons 

Any landholding polygon that overlaps with another (greater than a certain amount) is 

highlighted with a red fill in the Landholding Overlap layer. Visually identify each one and 

check them against the orthophoto and the data collected (ODK/GPS) layers. 

 
Figure 28: Polygon overlaps resulting from misidentification of fields 
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Overlaps may be the result of one or more of the following causes: 

› Data collection inaccuracies in defining the polygon shape and boundaries, resulting in 

small overlaps with neighbouring polygons.  

› Data collection error misidentifying the field polygons. 

› Disputes between two landholdings claiming the same land. 

Many small overlaps can be fixed quite quickly. However, some of the smaller ones can be 

difficult to identify visually. In these cases, the attribute table can be used to identify them: 

› Right click on the Landholding overlap layer > Open attribute table 

If necessary, filter the data in the table so that only records in one chiefdom are visible. Then 

order the records according to Overlap in area (sqm). Even the smallest overlap errors can 

be identified this way (and can be fixed), but QGIS can do this automatically (refer to the 

QGIS manual). 

 
Figure 29: A small overlap identified using the Landholding overlap attribute table. 

Note that the landholding overlap layer is a ‘materialised view’ of the database tables that is 

refreshed periodically. Fixing a small overlap will not result in the overlap fill disappearing 

immediately; it will disappear when next the view is refreshed. 

Mis-identification of fields can be more difficult to fix but possible by deducing the correct 

location from patterns of land use. For instance, in the figures below, it is apparent that the 

two sets of fields are cultivated differently and therefore probably belong to different 

homesteads. But if not sure, refer the case back to the field teams for verification.  
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Figure 30: Before (left) where 2483-3 is too far east, and after (right) where 2483-3 moved west and 

over fields with similar cultivation. 

Overlaps caused by exaggerated or mistaken claims or disputes are the most obvious and 

cannot be edited and must always be referred back to the chiefdom for resolution. 

There may also be cases of overlapping polygons, but different homestead and landholding 

numbers, which may represent a duplicate rather than a disputed claim. This can arise where 

different enumerators visit the homestead on different days and interview different family 

members. This can be checked in the attribute tables, and if the name and ID number of the 

homestead head are the same in both cases then one of the two records (in both tables – 

homesteads and landholdings), usually the later one, can be deleted. 

4.1.3 QGIS Checks 

In addition, QGIS has a Topology checker function that also identifies where landholding 

polygons overlap but it also identifies gaps and other 'topological errors' (see QGIS manual). 

The topology checker contains two useful rules – to check that homestead (points) fall inside 

landholding polygons, and to check that polygons do not have invalid geometries. 

Before executing the topology checker, filter the layers to check only those records for 

checking. If the data is not filtered, the check will be run on the whole spatial database! 

From the menu bar: 

› Vector > Topology Checker > Topology Checker 

The Topology Checker panel will appear.  
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› Select the ‘tool’ icon to define the check. 

 

› Configure the topology rule settings, by using the drop-down lists followed by [+ Add 

Rules] to include all the following: 

 

› Click [OK] to close the topology checker configuration box, then click on the large tick 

mark to run the check to validate all rules on the selected data layers and selected 

(filtered) records. 

The errors found will be listed in the topology checker panel. 

 

› Check all the errors listed.  

Highlighting the row in the topology checker panel will highlight the point or polygon in the 

QGIS window. To zoom to the features listed, use the relevant attribute table. 

In addition, but probably ‘overkill’ is a vector geometry tool to check validity. The check 

validity function will duplicate both the QC and topology checks already done and identify 

even the smallest geometry errors. Usually it is not necessary to check validity if both the QC 

and topology checks and corrections are done. 
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4.1.4 Visual Checks 

Lastly, systematically scan across the area of interest to check for the following errors: 

› Polygon sides not aligned with orthophoto (see rule 2 above) 

› Small gaps between polygons of adjacent landholdings 

› Other errors not detected by topology or geometry checks 

4.2 Chiefdom Validation 

After field data has been collected and processed (edited) it must then be returned in two 

stages to the chiefdom for validation (correction and acceptance). The two stages are: 

› Correction and validation by the inner council 

› Correction and validation by the whole community 

Data are reported, in the same way in both stages, in the form of: 

› Landholding maps 

› Landholding lists 

Errors and omissions identified in the first stage are corrected and incorporated into the data 

before it is presented for second stage validation. 

4.2.1 Landholding Maps 

A map, or maps in larger chiefdoms, is prepared that shows the following: 

› Orthophoto map background 

› Landholding polygons, with homestead number and landholding field labels 

› Homestead locations, with homestead number label 

› Community land, such as grazing lands, schools and dip tanks, with name 

› Map title, scale bar and north arrow 

The map scale may vary, depending on the density and size of landholdings, but it should 

clearly show each polygon and the homestead and landholding labels within the polygon and 

without the text overlapping. 1/5,000 is often a suitable scale at A0 plot size. 

4.2.2 Select Area of Interest (Chiefdom) 

The preparation of landholding validation maps is done on a chiefdom basis. Therefore, the 

map must show only homesteads and landholdings related to one chiefdom. 

Rather than use the homestead and landholding layers in the edit environment, which means 

having to filter the data, instead create a new QGIS project with a chiefdom data 

environment. 
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› Start QGIS (do not open an existing project file) or close the existing project and create 

a new project. 

› Click on the SLAM Edit Environment icon.  

 

› Enter your database credentials (user name and password). 

 

› Click [Test connection and load project types] 

› A message about a successful connection should appear. If not, check your connection, 

username and password (see figure below). 

› Note also that the Project type drop down list now has an entry. There are three 

options: 

› Edit – this will load all relevant layers for the whole database and appropriate 

styles. 

› Chiefdom – this will load only the data for a (yet to be specified) chiefdom with 

appropriate layers and styles for final data delivery. 
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› All chiefdoms – this will load all the landholding parcels in the database in a styles 

that colour-codes parcels according to the chiefdom. 

 
Figure 31: QGIS SLAM edit enviroment plugin 

› For chiefdom validation purposes, select Chiefdom from the project types. 

› With Chiefdom showing in the Project types, select the second tab Set Edit Environment. 

› Usually it is not necessary to Refresh the list of edit layers. However, nothing serious 

will happen if you do. 

› The drop-down list labelled Chiefdom contains an alphabetically order list of all 

chiefdoms. Choose the chiefdom name. 

› With the Chiefdom name showing in the drop-down list, click Load Chiefdom Layers. 
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Figure 32: QGIS SLAM set chiefdom environment 

› A pop-up dialogue box should appear telling you that the environment was successfully 

loaded. 

 

› Click [OK] and the chiefdom data together with other layers will appear in the QGIS map 

window together with a confirmatory message that the environment was successfully 

loaded. 
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Figure 33: QGIS SLAM chiefdom environment 

› By default, the Grid layer is turned off. Turn it on to see the orthophoto map sheets 

needed to cover the chiefdom area. 

› Add each orthophoto via Layer > Add Layer > Add raster layer >   

 

› Click the […] box to the right of the Source Raster Dataset(s) box and navigate to the 

folder containing the orthophoto. Load them at the bottom of the layers list. 
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› If the ortho does not appear in the QGIS map window where you think it should, it is 

probably due to a coordinate reference system issue. To sort this out, refer to paragraph 

1.4 Orthophoto Image Files to sort this out. 

4.2.3 Map Production 

Next select Print Composer and prepare one or more maps for printing. In most cases more 

than one sheet will be needed to cover a chiefdom, therefore an index map will also be 

needed. 

Start by producing an overview map of the whole chiefdom that will be used as the basis of 

the index map. 

› Project > New Print Layout > Create print layout Title  

› Provide a suitable name for the title, e.g. chiefdom_name Index 

  
Figure 34: Empty map layout window 

› Right-click anywhere on the map layout canvas to open a page properties dialogue box. 

› Change the page size to A0 

To add a map view to the layout… 

› Add item > Add map > (click top left of canvas and drag box to bottom right) 

› Alternatively, use the Add a new map to the layout icon. 

The QGIS map window will now appear in the map layout canvas. 
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The scale of the map will now reflect the size of the map on the layout canvas. Change the 

scale to something appropriate so that all the chiefdom polygons fill the whole map canvas. 

› Item properties > scale = 10,000 (for example) 

 
Figure 35: QGIS map composer 

The map extent can be moved to make final adjustments to the map layout. 

› Layout > Move contents (click on map and drag to position) 

Using the index map as a 'frame' for larger scale maps that show landholdings in more 

detail. The area and size of landholdings will dictate the scale of the maps. Typically, the 

detail maps will be between 1/5,000 and 1/7,000 scales. 

Using the index map in map composer, add a map frame: 

› Add items > Add shape > Add rectangle 

› Draw rectangle with approximate size for map frame that covers a part of the index 

map. 

Adjust the size of the rectangle corresponding to your map frame for the plot sheet size. For 

example, an AO plot of 1/7,000 scale will have a rectangle size of 400mm wide by 300mm 

high. 

› In the items panel > select rectangle > position and size (width = 400mm, height = 

300mm) 
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› Position the frame to cover the area of the detail map. 

 
Figure 36: Index map showing the (white) rectangle representing the detail map frame 
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The next step is to create a new map based on this frame. To do this a new map is created. 

› Layout > Duplicate Layout 

› By default, the current map name is added to the title box. Type in a new name of your 

new map (e.g. chiefdom_sheet_1). 

› In the new map layout window, delete or unselect the rectangle(s) and change the scale 

of the map to the required scale. 

 

› Move the window to cover the area of the index that corresponds with the area covered 

by the detail map frame / rectangle. Switch between the two map layouts to verifiy the 

new map frame corresponds to the rectangle (frame) in the index map. 

› Layout > Move Content 

 
Figure 37: Layout window showing new map of the area within the rectangle on the index map 
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› Repeat the creation of frames/rectangles and detailed maps that correspond to these 

frames until the all the landholdings shown on the index map are covered by detailed 

maps. 

The index map should now a series of white rectangles, each overlapping the next by a small 

amount. Add an index number to each rectangle corresponding to each detailed sheet 

number. 

 
Figure 38: Example of a sheet index map 

4.3 Landholding Lists 

Two lists of all landholding data captured in the chiefdom containing the same data but 

indexed differently, are required: 

› By homestead number 

› By homestead head name 

4.3.1 Connecting to the Server Data 

The data is held in PostGIS tables on the server, but the list can be produced using Microsoft 

Excel on the desktop computer. 

› Start Excel and begin with a blank, empty worksheet. 

› Data > Get Data > From Other Sources > From ODBC 
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› From the ODBC dialogue box select SGD odk_prod 

› Select [OK] and the ODBC Navigator box appears (below)  

› Click on the arrows to open odk_prod and public. 

› Select list_homestead_validation from the list of database tables and views. Note, do 

not choose list_homesteads (which is for the final lists).  

› A preview of the view appears... 

 

› Select [Edit] to open the database table. Note: in later versions of Excel the [Edit] 

button will be named [Transform Data]. 

› Refresh the view. 

› Click the down arrow for chiefdom_list to open the filter and sort box > Load more to 

show the complete list of chiefdoms. 
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Figure 39: Sort list of all chiefdoms 

› Unselect all > Select the box for the chiefdom > [OK] 

Only the chiefdom records will now appear, sorted by homestead_id. Note that the 

homestead_id is used for validation lists whereas the landholdings_id is used for the final 

lists. 

› Click the [Close & Load] button to load the filtered records into the worksheet. 

Either the worksheet can be saved and printed for the chiefdom validation lists or the data 

copied and pasted into the validation list template (ValidationList_template.xlsx). The 

template is already set up with the page headings, column headings, etc. If the template is 

not used, set up the page size, print area, column headings, etc. in the 

list_homestead_validation worksheet. 

Save worksheet with the chiefdom name and ‘validation list’ as both an Excel spreadsheet 

and a PDF file for printing. 
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4.3.2 Printing Validation Lists 

Validation lists are usually printed on A3 size paper. This can be problematic when printing 

directly from Excel, so it is recommended to print from a PDF file copy. 

Two sets of validations lists are required – one listed by homestead number and the second 

by homestead head name. 

4.4 Results of Data Validation 

The maps and lists are delivered to the chiefdom for their scrutiny and any corrections 

needed. These corrections will be made on the printed maps and lists. 

4.4.1 Polygon edits / corrections 

Correcting the landholding map is made by editing polygons in QGIS in the usual way (see 

3.4). If a homestead landholding polygon is to be deleted completely, for example in the 

case of a double claim or unauthorised household divisions of a homestead, delete the 

homestead and landholding using QGIS attribute table views and not the map view. The map 

view will update automatically on deletion of a record in an attribute table.  

4.4.2 Attribute data edits / corrections 

Using QGIS, edit the polygons to capture the corrections and changes made by the chiefdom. 

For corrections and changes to the attribute data lists, QGIS is also used. 

› Start QGIS in edit mode, either a new project or existing edit environment project. 

› It is not necessary to filter the homesteads according to chiefdom, but it may help to 

locate the record for editing more quickly. See 3.3 on how to filter records. 

› Right click on Homesteads > Open attribute table 
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Figure 40: QGIS attribute table edits 

The homesteads attribute table will open in a docked window below the map window. It is 

important to ensure that, for editing purposes, the attribute table is in form view and not 

table view. To switch between form and table views, use the buttons in the lower right 

corner of the attribute table dock window. 

› Either scroll down to the homestead number to edit or use the [Select/filter features 

using form] button to input the homestead_id to edit. Click the [Zoom to feature] button 

to show the polygon in the map window. 

› To edit, for example, the name of a homestead head spouse, in form view select the 

homestead head tab, scroll down to the homestead_spouses_relation box and to edit 

the spouse details, select to highlight the number in the relation box. If there is more 

than one number, this means there is more than one spouse.  
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Figure 41: Homestead spouse name edit example 

4.5 Generate Landholdings Id 

At the time of initial data collection, homesteads are labelled with a system generated 

identification number, the homestead_id, which is a sequence number, unique within the 

whole database, assigned in the order of the homesteads records arriving from the field and 

being loaded into the server.  

After the quality control and any editing and updating of the homestead records, a 

landholdings id will be assigned. The landholdings id is a unique number within the chiefdom 

to identify a homestead with all its fields (used or borrowed in/out). 

Assigning the landholdings id is not automatic but a database administration function that 

works in the QGIS SLAM edit environment (see Figure 42 below). 
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Figure 42: QGIS edit environment database administration 

A database stored function admin_assign_landholding_id is available to generate and assign 

landholdings id’s, with a parameter for the name of the chiefdom. The numbering starts at 

the north-west corner to the south-east corner. The QGIS plugin (sheet Database 

Administration) facilitates the use of this function.  

Note: The parameter to overwrite the landholdings id’s is by default set to false, which 

means that homesteads already assigned with a landholdings id will not be renumbered; only 

the new/unassigned homesteads will be assigned a landholdings id. Setting this parameter to 

true, will re-assign all homesteads within the chiefdom. 
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5 Data Delivery 

SLAM data delivery includes the following: 

› Set up laptop computer 

› Prepare the chiefdom geopackages 

5.1 Hardware Set Up 

The computer hardware for SLAM data delivery comprises a laptop computer. No other 

hardware is involved. The laptop must be configured using Microsoft Windows 10 Home (or 

better) operating system. SLAM or the [chiefdom name] is the only user account and has 

administrator privileges. Refer to Appendix A for more on hardware set up. 

5.2 Software Set Up 

Delivery of SLAM data requires software to be installed and set up on a laptop computer.  

› Establish a connection to the SLAM server. 

› Install QGIS 

› Configure QGIS 

Refer to Appendix C for instructions on how to set up and configure the necessary software. 

5.3 Chiefdom Data Set Up 

Each chiefdom receives a copy of the SLAM database comprising the 

layers shown in figure. Note that the data layers do not include the 

chiefdom. This is because the chiefdom dataset was collected by the 

Elections and Boundaries Commission and the SLAM project cannot 

and must not distribute chiefdom boundary information. 

Creating a sub-set of the SLAM database for each chiefdom can be 

done on the chiefdom laptop or another computer and copied across. 

However, if the changed user interface has already been applied, it will 

not be possible to create the chiefdom data packages. Therefore, 

either create the chiefdom data packages on another computer or 

start QGIS with no customization as described in Appendix C. 

5.3.1 Chiefdom Data Packages 

› Start QGIS with a new / blank project. 

› Start the SLAM plugin: 

› Provide your database credentials (i.e. username and password).  

Figure 43: SLAM chiefdom data set layers 
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The tool should remember credentials after completing the setup of the edit environment. 

The tool can only be used by users that have user authorisation in the PostGIS database. 

 

› After entering the password, click [Test connection and load project layers].  

A message should appear that the connection was successful. The project types also now 

appear in the bottom selection field. 

› After successfully connecting, do not set the CRS (this can be left unchanged), but 

choose the project type.  

› Click on the menu bar, which by default will show [Edit], to select the option 

[Chiefdom]. 

› After selecting Chiefdom, select the Set Edit Environment tab, which enables a review of 

the layers that the tool will load. Usually, there is no need to deselect any of these 

layers. Occasionally it may be necessary to [Refresh the list of edit layers] if any 

changes have been made in the SLAM database. 

› Next, choose the chiefdom name, then [Load Chiefdom Layers].  

Note, it may take a minute or so for all the layers to load and then appear/render. 

A message window will open saying the environment was successfully loaded.  

› Select [OK] to continue.  
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Figure 44: QGIS SLAM chiefdom environment 

Although the data may initially appear upside down in the process, it will at the end be the 

right way up. 

Usually, the point and polygon text, line and fill styles will load by default from the database. 

However, if there is a need to change the style definitions this can be done now (before the 

chiefdom package is created). Either load a style from the database (PostgreSQL) or define 

them manually. 

› After the layers have loaded, the next step is to create or copy the layer on or to the 

laptop. Create folder on the laptop in the user directory. 

› This PC > Windows (C:) > Users > SLAM > SLAM 

› Select the     plugin again and select the Create Chiefdom Packages tab.  

› Browse to the Output directory 

 

› Select Geopackage. The consolidated zip file is not needed when creating the 

geopackage directly on the chiefdom laptop.  

› Then click Create chiefdom package. 
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› Next, the orthophotos that cover the chiefdom area need to be identified and copied 

manually on to the chiefdom laptop. Use the grid layer to identify which orthophotos to 

copy. Copy them to same folder as the other layers. 

› In the QGIS layers panel create a group and name it Image maps.  

 

› Highlight the Image maps group and add the orthos: 

› Layers > Add Layer > Add Raster layer > 

5.4 Chiefdom Register  

In addition to SLAM QGIS data, each chiefdom laptop will have, as PDF files, the following: 

› Landholding register 

› Landholding lists 

› Landholding maps 

These are all Adobe Acrobat PDF files that are readable with Adobe Acrobat Reader software. 

5.4.1 Creating the Landholding Register 

The landholding register is produced with Microsoft Excel and Word software using an ODBC7 

connection to the SLAM odk_prod database. 

                                                
7 Open Data Base Connection (ODBC) 
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An ODBC driver must be installed, otherwise the option to select SGD odk_prod database 

(below) is not available. Refer to Appendix A.4 on how to install an ODBC driver for MS 

Excel. 

› Start Excel and create a blank spreadsheet. Save the spreadsheet now or later as 

[Chiefdom_name] Landholding Register.xlsx. 

 
Figure 45: Excel > Data > Get Data (from external source) 

›  Data > Get Data > From Other Sources > From ODBC > SGD odk_prod 

 

› Select odk_prod > public > View_homesteads 
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Figure 46: Excel ODBC connect to odk_prod and View_homesteads table 

› Click [Edit] (or [Transform Data] in later versions of Excel) to filter and select only the 

needed chiefdom data. Refresh the view if necessary. 

› The view of the database contains all records for all chiefdoms. Click the down arrow in 

the chiefdom_list column and select the chiefdom name. 

 

› Click Load more options (chiefdom names) to the list if necessary. 

› Uncheck the box (Select All) and check the box for the chiefdom, then [OK]. 
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› The chiefdom records will not be sorted according to the landholdings_id, so click the 

down arrow on the column heading landholdings_id, and Sort Ascending. 

› If the landholdings_id shows zeros (‘0’) this means the landholdings ids have not yet 

been assigned (see 4.5). 

› Next, select [Close & Load]. It may take a few seconds for the data to load and appear 

in the worksheet. A side panel will display how many rows / records were loaded. 

› Rename the worksheet to DATA. Note: an error will appear later if the worksheet is not 

renamed to ‘DATA’. 

› Save the spreadsheet with the chiefdom name and exit. 

› Make a copy of the Chiefdom Landholding Register TEMPLATE.docx file and open it. 

There is no need to rename the file (template) at this stage; it will be saved with a new 

name after the records are merged (imported). 

A dialog box may appear asking to run an SQL command embedded in the file. If so, 

select [Yes]. If the above dialogue box appears, another dialog box will open asking for 

the location of the source data; this is the Excel file just created earlier. 

 

› A Word document opens showing the <<place holders>> for the data. 
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Figure 47: MS Word chiefdom landholding register template 

› To import data: select > Mailings > Select Recipients 

 

› Of the three options, select > Use an existing list 

› Select the Excel file created with the chiefdom name > [Open] 

 

› Select the table named ‘DATA$’ 

› Nothing will appear, so click on <<Preview Results>> to see the records inserted into 

the template. 
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› The first record in the Excel worksheet will appear on the first page of the register. This 

should be landholding number 1 in the chiefdom, and if so, skip the next step. 

If the records appearing in the word document do not start with landholding 1 then: 

› Select > Edit recipient list. 

 

› In Mail Merge Recipients box click [Sort]. 

 

› In the box [Sort by] click the down arrow and select landholdings_id from the list. Check 

that the button shows [Ascending].  

› Close the box by clicking [OK]. 

The chiefdom register word document should now contain all the records starting at 

landholding 1. Select Preview the results and navigate                                  to display each 

record in turn. To end: 

› Select > Finish and Merge. A dropdown menu appears with 3 options… 
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› Select > Edit individual documents … to create a MS Word document (preferred option). 

Alternatively, print documents can be used to send the register directly to a printer (not 

recommended) or to print a PDF file. 

 

 

› All records must be merged, so select [OK] to merge to New Document.  

Note: it may a few minutes to create the DOCX or PDF file, depending on the number of 

records (homestead landholdings) in the chiefdom. 

› Save the file with the chiefdom name and “landholding register”. 

The register can be printed from the DOCX file, but a PDF copy will also be provided to 

the chiefdom on their laptop. 

› Save the file with the chiefdom name “landholding register” as a PDF file. 

After the PDF file is created (either by saving the DOCX as PDF or printing direct to PDF), 

pages must be inserted to complete the landholding register ready for delivery. The following 

pages must be added: 

› Title page (chiefdom name, ‘landholding register’ and date register was created) 

› Example page (immediately after the title page) 

› Blank pages (10, 20, 30, depending on the size of the register) 

A template is available for the title page as a DOCX file. Edit it and save as a PDF. Insert the 

PDF page as the first page of the register. 

› Insert the example page PDF file as the second page of the register. 

› Insert the blank pages at the end of the register. 
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5.4.2 Creating Other Chiefdom Documents 

In addition to the landholding register, each chiefdom must receive the following documents: 

› Copy of landholding maps 

› List of all landholdings (A3 size) 

› Index lists – by new landholding number, old homestead number, and by name. 

› Copy of chiefdom LIMS manual 

› Copy of chiefdom land records maintenance manual 

Refer to section 4.2.1 for guidance on the production and printing of landholding maps. 

The need for index lists is because a different set of identification numbers is used for the 

final data – landholding numbers – whereas the data collection and validation used 

homestead numbers. Landholding numbers are in the range 1-n for each chiefdom whereas 

homestead numbers are 1-n for the whole database / country. 

To prepare the final results list of all landholdings: 

› Start Excel with a blank spreadsheet 

› Connect to the database 

› Data > Get Data > From Other Sources > From ODBC 

› Select the SGD odk_prod source from the dropdown list. [OK] 

› From odk_prod open the public folder and select List_homesteads, then [Edit] 

› From the umphakatsi column select only the records for the relevant chiefdom. Load 

more chiefdom names if necessary. 

› With only the relevant chiefdom records showing, select Close and Load. 

› Use either the list homesteads template for printing or set up the page size, header, 

column headings etc in the current worksheet, 

To prepare the index, connect to the SLAM database using Microsoft Excel. 

› Start Excel with a blank spreadsheet 

› Connect to the database 

› Data > Get Data > From Other Sources > From ODBC 

› Select the SGD odk_prod source from the dropdown list. [OK] 

› From odk_prod open the public folder and select View_homesteads, then [Edit] 
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› From the chiefdom_list column, select only the records for the relevant chiefdom. Load 

more chiefdom names if necessary. 

› With only the relevant chiefdom records showing, select Close and Load. 

› Delete all the columns not needed, i.e. leaving only the homestead number (id), 

landholdings number, surname, given name and other name columns. 

› Sort the data 3 times, by homestead number, landholdings number and surname, and 

each time copy the records and paste them into a DOCX file as separate tables. 

5.4.3  Copy and Complete 

The final step is to copy the chiefdom geopackage layers, the maps and the lists to the 

laptop. 
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Appendix A IT Technical Guide 

A.1 Tablet Computers Set Up 

These notes refer to the tablet computer Samsung Galaxy Tab Active (SM-T365). 

After switching on, the tablet will require input on: 

› Language = English (United Kingdom) 

› SIM card = skip 

› Wi-Fi = Provide a Wi-Fi that is connected to the Internet 

› User agreement = ✓ 

› The tablet will check for and download updates – this may take a while 

› Tap & Go = skip 

› Google sign in = slamcowisd@gmail.com & password = slamcowi101 

› Date & time = Harare GMT+02:00 

› Google services = uncheck all the boxes 

› Samsung account = skip 

› Dropbox = skip 

› Device name = SLAM# (where # is the next number assigned, see inventory list) 

› Note the serial number and IMEI number (Device > About > Status) 

The tablet is now ready to use. Suggest that unused apps and icons are removed from the 

home screen and the tablet. 

Recommend that some settings are changed to make the tablet easier to use: 

› Device > Display > Smart stay = ✓ 

› Device > Display > Screen timeout = 5 minutes 

The data collection software is called GeoODK Collect and can be downloaded from the 

Internet. 

› Connect to the Internet 

› Sign in to Google using slamcowisd@gmail.com with current password (credentials) 

› Go to The Play Store, search for and download GeoODK 

A.1.1 Configure GeoODK 

The GeoODK8 app is used for field data collection. Before using the app for the first time, it 

needs to set up or configured, for example with regard to connection to ODK Aggregate web 

application, running on the server, and required for receiving and storing data collected in 

the field. 

› Go to Settings > General Settings. 

                                                
8 http://geoodk.com  

mailto:slamcowisd@gmail.com
http://geoodk.com/
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› Go to Server settings > Configure platform settings. 

Use the following data to configure ODKAggregate server settings: 

URL = http://192.168.8.2:8580/ODKAggregate/  

Username = [data_collector] 

Password = [password] 

› Go back to GeoODK > General Settings 

The remaining options in General Settings can remain as default. 

› Go back to GeoODK > Settings 

No changes are required to Admin Settings. 

› Go to Map/Theme Settings 

› Uncheck Online Maps (so that maps are offline) 

› Theme options > Set default theme = classic 

Next, a data collection form needs to be copied from the server:  

› Go to Form Management 

If not already provided, the server will require authentication: 

http://192.168.8.2:8580/ODKAggregate/
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› Got to GeoODK Collect > Get Blank Forms 

The following forms/questionnaires can be used in field data collection:  

› Capture Community Area (201808) 

› Landholding and Land Use Data Form (201808) 

 

› Press “Get Selected” 

 

Forms are now loaded and ready to use! 
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A.1.2 Copy Image Files 

Prior to fieldwork, the necessary orthophotos covering the area of interest must be copied to 

the tablet computer. 

These orthophoto are specially formatted for use on a tablet, and orthos in other formats 

such as JPG, TIFF or ECW formats cannot be used. The format is called MBTILES9 and image 

files have the mbtiles suffix.  

› Identify the required MBTILES files on the server at: 

› Z:\\192.168.8.2/geodata/imagery/MBTiles/ 

› Copy the subdirectory containing the mbtiles file, and not just the file itself, to the 

following directory in the tablet computer: 

› Internal storage\geoodk\OfflineLayers 

The naming convention is the same as for other orthophoto files, but they may be divided 

into four (because of file size limitations in GeoODK software). The file name also indicates 

the resolution (i.e. zoom level10) of the ortho image. For example: 

› K11_z19.mbtiles (ortho index tile K11 with a resolution of zoom 19) 

› J06_z20 (ortho index tile J06 with a resolution of 20) 

A zoom 20 file is a higher resolution than z19. For most areas a zoom 20 file provides 

sufficient resolution. A zoom 19 may be appropriate in less densely populated or farmed 

areas. 

Refer to Appendix B for guidance on creating MBTiles using TileMill software. 

A.2 Troubleshooting GeoODK and Data Collection 

Slow Tablet Performance 

If the tablet begins to 'slow down' restart the tablet. 

› Power off > Restart 

This will clear the data cache freeing up memory for applications to run more quickly. 

Also check that the device storage is not full or near full. If so, first try deleting any 

unneeded programs and files. If necessary, delete some GeoODK data that has been 

successfully uploaded to the server. 

                                                
9 https://wiki.openstreetmap.org/wiki/MBTiles  
10 https://wiki.openstreetmap.org/wiki/Zoom_levels  

https://wiki.openstreetmap.org/wiki/MBTiles
https://wiki.openstreetmap.org/wiki/Zoom_levels
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GeoODK App Crash 

If GeoODK crashes or stops working, the issue is often the size of the orthophoto image or 

too many orthophoto images stored on the device and consuming memory.  

› Reduce the orthophoto image size (< 5GB; best between 2GB and 3GB) 

› Delete unneeded orthophoto image files 

To recover from a crash, navigate to the tablet’s android system settings:  

› Settings > Applications > GeoODK > [Force Stop] 

Do not clear data or clear cache because this will delete all data on the tablet including data 

that has not been uploaded to the server. 

› Restart GeoODK 

Tablet Factory Reset 

Sometimes it may be necessary, due to general problems with the tablet computer and its 

android operating system, to reset the tablet to its factory settings. This will delete all 

applications and data from the device, so only do this is you if you are sure all data are 

transferred to the server. 

› Power off the tablet 

› Press and hold together > Volume Up + Home button + Power button. 

 

› The android reset (robot) logo appears, followed by the system recovery menu. 



 

Appendices 

     

SLAM LIMS USER GUIDE   69  

 

› Using the volume down button, select [wipe data/factory reset] 

 

› Confirm that all data will be deleted: 

 

› Then confirm the option to reboot system now. 
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Data Does Not Upload or Transfer 

If the Upload Results say ‘Error: Network 

Connection Refused’, then: 

› Check if the Wi-Fi is turned on? 

› Check if the server settings have been reset. 

› Go to GeoODK > Settings > General Settings > Configure platform settings 

› Check the setting for URL, Username and Password (see beginning of section A.1.1) 

A.3 Resetting Laptops 

If and when necessary, the Lenovo Ideapad 310 laptop computers can be reset to their 

factory defaults. To do this… 

› Turn the laptop off. 

› Press the Novo button on the left side of the laptop case. The button is recessed in a 

small hole and a paper clip is needed to press it. 

› Select > System Recovery. 

› Restore form initial (factory settings) or user backup, as required. 

› If a restore to factory settings is chosen, then an Internet connection is needed to re-set 

up the computer. 
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A.4 Installing ODBC Driver for MS Excel 

Note that a connection from MS Excel to the PostgreSQL database will be made via Open 

Database Connection tools. The psqlODBC11 executables that need to be installed on a 

computer operating the MS Excel-PostgreSQL connection, are, in the order of installation: 

› psqlodbc-setup.exe 

› psqlodbc_x86.msi: for psqlODBC (32bit) 

› msipsqlodbc_x64.msi: psqlODBC (64bit) 

Both 32- and 64-bit programs are required to make a User DSN12 named “SGD odk_prod”; 

this has to be done on each computer. 

› In the Windows Search box type ODBC and choose ODBC Data Sources (32-bit). 

 

› In ODBC Administrator, Add a new User DSN. 

 

                                                
11 https://www.postgresql.org/ftp/odbc/versions/msi/  
12 https://support.microsoft.com/en-us/help/966849/what-is-a-dsn-data-source-name  

https://www.postgresql.org/ftp/odbc/versions/msi/
https://support.microsoft.com/en-us/help/966849/what-is-a-dsn-data-source-name
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› Scroll down the list and choose PostreSQL Unicode. Click [Finish]. 

 

› In the PostgrSQL driver set up box, type in the details as shown below: 

 

› Data Source = SGD odk_prod 

› Database: odk_prod 

› Server: 192.168.8.2 

› User name: e.g. johnsons 

› Password: ******** 

› [Test] the connection and [Save] the [Ok] to exit the ODBC Administrator. The driver 

should now be installed and available in MS Excel. 

To test the ODBC link and the connection to the SLAM database… 

› Start MS Excel. 

› Select the Data menu tab > Get Data > From Other Sources > From ODBC 
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› Select [Load] for all data, or select [Edit] to choose columns and if required filter and 

sort order. 

 

› Close and load. 
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Appendix B Creating MBTiles 

MBTiles is a raster image file format. The files are compressed and hold geographic location 

and projection information. The format is specifically designed for use in web or mobile 

applications. MBTiles is an open source specification and based on SQLite. 

B.1 Software 

Various software can be used to create MBTiles files. The preferred application is called 

TileMill13. Information in addition to this training guide can be found in the software 

documentation at the mentioned URL. 

B.2 Create an MBTiles Format File 

› First make sure that GeoTIFF imagery is available. If necessary, convert the orthophoto 

file format into GeoTIFF using Global Mapper, QGIS or other software. TileMill only 

works with GeoTIFF format input files.  

 

› Start TileMill and create a new project. Include default data in the project – world layer 

and styles – as this will help to geo-referencing the image, i.e. to locate the orthophoto 

to be converted.  

 

                                                
13 http://tilemill-project.github.io/tilemill/  

http://tilemill-project.github.io/tilemill/
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› The new project is added to the projects window. Select the project… 

 

› Select the Add Layer to add the GeoTIFF image.  

 

 

› Use the [Browse] button to locate the GeoTIFF file that will be converted to MBTiles. 
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› Set the SRS to WGS84.  

› Save & Style (the style is needed to depict the ortho) 

› The edit window will then reappear, with image file (H11) added to the project layers. 

Note that in this example the layer is named H114326. The ‘4326’ added to the sheet 

number represents the ESPG coordinate reference system code for WGS84. 

 

› Click [Export] and from the from down list, choose MBTiles.  

› Then your TileMill window should be like that below: 
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› Next, adjust the bounding box, highlighted above, to coincide with the image. To make 

this adjustment, select and drag the sides of the box to resize it. Click the [Zoom +] 

button to resize the box. Repeat and drag the box to locate the image in its geographic 

location. If you are prompted ‘Delete this point’, select [Yes]. 

 

› Continue adjusting the size and zoom so that the box coincides with the image. 
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› In the Zoom slider, move it until the desired zoom number appears in the slider bar. The 

zoom number represents the MBTiles image resolution. A zoom of 20 is usually used; 

sometimes 19 when a slightly lower resolution will suffice.  A zoom of 21 or 22 will 

result in large image file sizes.  

› Centre: click somewhere within the bounding box to set centre. 

› Click “save settings to project” and press Export, a 48 km² ortho takes about 1.5 to 2 

hours to process depending on the speed of the PC.  The resource of the PC will be 

almost fully used, so use a PC dedicated to this task.  Use view exports to view 

progress, multiple tasks can be run simultaneously. 

› When done, press (in view exports), this will load the MBTiles. 

› Store the MBTiles file in a folder for MBTiles for later copy/transfer to a tablet computer. 

Hint: A full size GeoTIFF orthophoto tile will result in a large MBTiles file size, especially 

if Zoom 20 is needed. Large MBTiles file size can cause problems in tablet computers 

with limited memory. Two options are available. Use a lower resolution zoom setting, 

e.g. 19, or smaller image extents. For example, instead of creating one large MBTiles file 

for an orthophoto tile, create four smaller ones. 
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Appendix C QGIS Set Up 

› For setting up software, a temporary connection is needed to the server. Connect to the 

WiFi 

Wireless SSID SlamDataCollection 

Password slamWifi102 

  

Server \\192.168.8.2 

› Make the laptop discoverable on other networks (turn on network discovery). 

All computers connected to the wireless router, except for the server, will now be listed 

in the network. 

› To connect to the server, a network drive must be defined / mapped. Use the folder IP 

address for the server specified above. The laptop may need to be restarted to finish the 

connection. 

 

› Click [Browse] to choose the network folder to map and connect to: 

› D SLAM EXDR02 Geodata 
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The server folders will now be mapped to drive Z: as shown below. 

 

› Next, copy from the software and hardware folder to the laptop and double-click to 

install the following software: 

› QGIS-OSGeo4W-3.4.0-1-Setup-x86_64.exe (the QGIS Standalone Installer [64 

bit]14 

› LibreOffice_6.0.6_Win_x64 

› Adobe Acrobat Reader 

C.1 Install QGIS 

Version 3.4 ‘Madeira’ (the April 2019 Long Term Release) can be found on the server at: 

› Z:\\192.168.8.2/D SLAM EXDR02 Geodata/Software and Hardware/QGIS 

                                                
14 https://qgis.org/en/site/forusers/download.html  

https://qgis.org/en/site/forusers/download.html
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› Copy the file QGIS-OSGeo4W-3.4.6-2-Setup-x86_64.exe (the so-called QGIS 

Standalone Installer [64 bit]) to the computer workstation. The computer must be 

using Windows 10 64-bit version. 

› Double-click the QGIS set file. 

› During the installation of QGIS, accept all the defaults during the installation process. 

› Copy the QGIS 3.4 Desktop shortcut to the start menu and desktop and delete the QGIS 

installation file and shortcuts folder. 

› After installation, start QGIS, which will open with an empty project window with a user 

interface, as depicted below. 

 

Configure User Interface 

A simplified QGIS user interface is necessary for computers in use in/by the chiefdom. Only 

the functions that are needed are available in the QGIS menus; all other functions are 

hidden. 

The QGIS user interface is customized using a *.ini file (e.g. “qgis3 chiefdom.ini”). which can 

be used for setting up the chiefdom laptops with a simple user interface. 

Customisation is enabled in the QGIS Menu:  

› Settings > Interface Customisation > Enable Customisation  

› A dialog Interface Customisation is shown, with the option “Load from File” by clicking 

the folder       and the qgis3 chiefdom.ini can be loaded.  
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The dialogue window will now show how the customisation will be applied, as shown 

below. Additional adjustments to the customised interface can be manually made, if 

necessary. 

› Click [Apply] and [OK] to finish. 

 

When restarted, QGIS will have the changed, stripped down user interface as shown below. 
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Applying the qgis3 chiefdom.ini file will strip away all but the most basic menu functions and 

therefore the process cannot easily be reversed. However, a full set of menus will be 

available if QGIS is started from the command prompt with the following command line: 

› cd c:\program files\qgis 3.4\bin 

› start “qgis” qgis-bin.exe --nocustomization 

Tip: the minimal UI means access to some menu functions are hidden but they are 

nevertheless available via keyboard shortcuts. The following are some of the most useful: 

Show the layers panel. Ctrl+1 

Show all layers Ctrl+Shift+U 

 

C.2 Edit Environment 

In previous versions of QGIS a manual connection would need to be established with the 

SLAM PostGIS server. However, version 3.4 uses a custom developed software extension or 

plugin (i.e. load_edit_env) to establish the connection and to set up the SLAM edit 

environment with all its layers automatically. 

Copy the plugin in the form of a load_edit_env20190326.zip file to the desktop computer. All 

(later versions of) QGIS plugins can be found on the server in the QGIS custom\Plugins 

directory.  

› Z:\\192.168.8.2/D SLAM EXDR02 Geodata/Software and Hardware/QGIS/SLAM Plugins 

To install the QGIS plugin: 

› In QGIS, go to Plugins > Manage and install plugins >  
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The list of installed plugins is shown. 

› Select Install from ZIP 

 

› Click on the […] button and navigate to the .zip file in the plugin directory: 

› Click [Install Plugin]. 

A message will briefly appear informing that the plugin is successfully installed. 

› Close the Plugins | Install from ZIP window. 

The plugin places a new icon  below the QGIS menus. 

› Note that another plugin “Search Chiefdom Layers” is available, primarily for the 

chiefdom equipment. The plugin is available in a similar ZIP file structure 

(searchchiefdomlayers20190308.zip) and can be installed in a similar fashion through 

“Install from ZIP file” (see Appendix E.1). 

 

To start the QGIS plugin: 

› Start the plugin by 

› Double-clicking this icon, or 

› Go to Plugins > Load SLAM Edit Environment > Load SLAM Edit Environment 

A Load Environment for SLAM window will open: 

› Provide your database credentials (i.e. username and password). The tool should 

remember credentials after completing the first setup of the edit environment. The tool 

can only be used by users that have user authorisation in the Postgres database.  

› After entering the password, click [Test connection and load project types].  
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An Info message should appear to indicate that the connection was successful (see 

below).  

 

› With Set CRS, the On-The-Fly (OTF) projection in the QGIS project can be chosen. 

› The project type can now also be selected in the bottom selection field: 

› Edit (default); for loading an Edit environment with the layers for editing. 

› Chiefdom; for preparing data in a format suitable for Chiefdom computers, only 

data relevant for a chosen chiefdom will be loaded. 

› All Chiefdoms; idem, but for the data in all chiefdoms, with landholding polygons 

colour coded by chiefdom. 
 

C.2.1 Project Type: Edit 

› Select project type Edit 

› Go to tab Set Edit Environment with the list of layers for edit environment 

› Select Load Edit Layers 
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All selected layers will then appear in QGIS map window with a message with a list of layers 

that have been loaded into the edit environment. Note that the layers are upside down when 

CRS EPSG:22291 was selected. 

 

› To finish setting up QGIS for data editing, raster image orthophoto map layers must be 

added. Turn on the grid layer to identify which image map sheets you want to load (e.g. 

L13).  

› Then, in the QGIS layers panel create a group and name it Image maps. Highlight this 

group and: Layer > Add layer > Add raster layer 

› Click the […] button and navigate to the directory on the computer (not the fileserver) 

where the ECW orthophoto maps are kept. 
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If the orthophoto does not load where it is expected, this means that QGIS has not 

recognised or incorrectly recognised its CRS. To fix this, right click on the image map number 

in the layers panel. In the pop-out menu, select Properties. 

In the example above, QGIS has partly recognised the CRS but placed the image in the 

northern hemisphere. To correct it, click on the Set source coordinate reference system bar. 

› Select from the list EPSG: 22291 – Cape/Lo31 then [OK]. The image map should now be 

in the correct location. 

C.2.2 Project Type: Chiefdom 

Preparing for delivery of data to the chiefdoms is also supported by the plugin: 

› Start the plugin and enter credentials 

› Press button “Test connection and load project types” 

› Select project type “Chiefdom” 

› Go to sheet “Set Chiefdom environment” 

› Select the chiefdom (e.g. Mbelebeleni) 

› Press button “Load Chiefdom Layers” 

A message will appear, reporting the environment has successfully loaded with the selected 

layers. More elaboration is provided in section 5.3.1 
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C.2.3 Project Type: All Chiefdoms 

Preparing a data delivery involving data for all chiefdoms would be similar to appendix C.2.2 

above: 

› Start the plugin and enter credentials 

› Press button “Test connection and load project types” 

› Select project type “All Chiefdoms” 

› Go to sheet “Set Chiefdom environment” 

› Press button “Load All Chiefdoms Layers” 
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C.3 Manual Connection 

Occasionally it may be necessary to establish a manual connection between QGIS and the 

PostGIS SLAM odk_prod database to add a layer from a database table. 

› Layer > Add layer > Add PostGIS layer 

 

The Data Source Manager window will open and by default the connection will be SLAM. 

› Click [Connect]. On the first occasion after initial installation – without setting up a 

SLAM edit environment – the connection will request your username and password for a 

new connection. Complete the connection information: 

› Name SLAM 

› Host 192.168.8.2 

› Port 5432 

› Database odk_prod 

A basic connection is all that is necessary, with your username and password. To finish, click 

[Test Connection]. 
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On subsequent occasions your credentials should be remembered by QGIS. 

› After the connection is established, the window will list the data schemas. Click the 

arrow next to the schema name to display the tables in each category. 

› boundaries – these show layers such as the regions and tinkhundla. 

› odk_prod – dedicated to collected field data. 

› osm – is open street map, with a copy of Open Street Map data from beginning 

2018, primarily to support field and office work. 

› public – these are the data layers and views of the data 

› reports – these are views and saved queries for report purposes. 
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Opening the public schema will reveal various tables and views. The layers prefixed ‘cd_’ are 

for ‘chiefdom data’ and ‘v_odk_’ for views of the collected data. 

 

› Manually select the layers that you want you want to appear in the QGIS map window. 
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Appendix D Database Administration 

1 Connect to the Server 

› Connect to the SlamDataCollection network.  

› Start Remote Desktop 

Adding and changing (the rights of) users can be done “manually” via pgAdmin, but the 

easiest would be to use the database administration section of the plugin. 

2 Using database administration section of the plugin 

› Start the plugin 

› Check/provide login details (for a user with slam_administration right). 

› Test Connection with these login credentials. 

› Go to Database Administration and select database function “Set User”. 

› Check/Provide Parameter Values: 

› Database user: following naming convention: lastname and first initial, all in 

lowercase, e.g. johnsons. 

› Password: note that the password here will be visible, but not during a normal 

logon to the database. 

› Database role; slam_read [read only use], slam_edit [for edit environment], and 

slam_admin [for performing db functions]. 

› Revoke right: true; undoing all rights that might have been previously ad-hoc 

provided. 

› Comment: will be stored in the database for administration purposes. 

Note that the same function can be used to update an existing user, e.g. to update password 

or database role. 
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3 Assign Landholdings Numbers 

The database administration function to assign landholdings_id numbers is described in 4.5 

on page 50. 

4 Using pgAdmin 

› Start pgAdmin and connect to the odk_prod database.  
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To load and run SQL scripts: 

› Tools > Query tool > Open file (or enter/copy/paste SQL statement) 

To create a user with edit rights: 

› Type in the following SQL script… 

select admin_set_user('trumpd', 'america1st', 'slam_edit', true, 'read only user Donald Trump', false) 

To change the same user to read_only rights (or to create the user as such): 

select admin_set_user('trumpd', 'america1st', 'slam_read', true, 'read only user Donald Trump', false) 

To change the user password: 

select admin_set_user('trumpd', 'america2nd', 'slam_read', true, 'read only user Donald Trump', false) 

OR  

Alter user trumpd WITH password 'america2nd' 

To delete a user: 

DROP ROLE IF EXISTS trumpd  

5 Automatic Server Tasks (Task Scheduler) 
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In the operating system Windows Server 2012, a program Task Schedular is available, which 

allows administrators to define server tasks that will run a set intervals. These task are 

based on batch files as depicted below: 

› ServerTask_backup_odk_prod_database.bat: runs the executable pg_dump.exe, which 

creates a backup of the odk_prod database, resulting in a file containing all data, its 

name labelled with database and date, e.g. odk_prod_20190319.backup. 

› ServerTask_odk_to_slam_automatic.bat: runs a database stored function 

odk_to_slam_automatic, which copies the collected information from mobile devices in 

the ODK Aggregate database (schema odk_prod inside the database odk_prod) to the 

edit environment (schema public). 

› ServerTask_refresh_materialized_views.bat: runs a SQL command for refreshing the 

materialised views. 
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Appendix E Chiefdom LIMS User Guide 

Landholding data is provided ‘off-line’ to each chiefdom. A subset of the SLAM database is 

copied and stored on the chiefdom laptop computer. An Internet connection is not necessary 

for viewing and querying a chiefdom’s landholding data. 

Chiefdom data is made available on the laptop for user SLAM. There is no password for this 

user. 

The software for viewing and querying chiefdom landholdings is QGIS 3.2. The software 

application is started by double-clicking the QGIS icon on the desktop, start menu or 

taskbar. 

 

QGIS software will appear with a start-up screen. Note if you are using QGIS version 3.4 a 

slightly different start-up screen to the one below will appear. 

 

The user interface for QGIS has been customized to remove all functions other than those 

needed for viewing and querying the data. 

  

Start QGIS by 

double-clicking 

the icon 
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The components of the user interface are indicated and described below: 

Map Window 

The main part of the screen (outlined in red below) is called the ‘map window’. Tools to 

navigate the map are available in the menu bar and the input device (e.g. mouse) buttons 

(e.g. mouse wheel zooms in and out). 
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Menu bar 

› The menu bar has both ‘drop-down’ sub-menus and function icons.  

 

› Clicking on [Project] will drop down a sub-menu. The top item [Open] will open a 

project data file but this is not needed because QGIS always opens project data. 

 

› [Close] will close the project data file and return QGIS to the Recent Projects List. 

Double-click the project bar to return to viewing data. 

› [Save] will save any changes, but because changes cannot be made, nothing will be 

saved. 

› [Exit QGIS] closes the software. 

› The [view] sub-menu provides tools for panning and zooming the map window. 

› [Pan map] changes the cursor into a hand so that the map can be moved around in the 

window. 
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› [Zoom in] and [Zoom out] make the map view bigger and smaller. Clicking once with 

the magnifier tool will zoom in a set amount. Clicking, holding and dragging the cursor 

will create a zoom window. 

 

› The [Identify feature] tool reveals attribute text data about a homestead or landholding. 

 

However, to reveal data about a homestead, the homestead layer in the left panel must 

first be selected and highlighted. By clicking the arrow point cursor on the green dot, 

which represents the homestead, will open a new window revealing data about the name 

of the homestead head, the area of land, and year of allocation. The homestead selected 

will appear in the map window with a red dot. 

› To reveal information about the landholding or homestead fields, first select and 

highlight the landholdings layer in the layers panel, then select anywhere inside the 

landholding shape. The landholding selected will be highlighted with a red boundary. 

› Similarly, selecting and highlighting the land rented in layer will enable features on that 

layer to be viewed and data revealed. 

› Clicking where there isn’t a feature on the selected layer will show no results in the data 

window. However, clicking a feature when all the data layers are revealed will list all 

those layers in the attributes window. Click the right-arrow (>) to open the layer data. 
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› Other tools are available for revealing more information about a landholding and 

searching on specific attributes, such as a person’s name. 

 

› To close / put away the identify results window, click on the in the top right corner of 

the identify results window box. Be careful not to click the uppermost  in the main 

window as this will close the QGIS program. If the layers window is closed accidentally, 

it can be brought back by pressing the [Ctrl] key and [1] key at the same time. 

› The [measure] tool shows the distance between two points identified by a cursor click. 
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In the above example, the distance between the two red dots that were clicked with the 

cursor is 76.99 metres. 

› Similarly, an area can be measured. Identify each point around the area in turn and 

right-click when finished to show the highlighted area in square metres. If needed, the 

area units can be changed by clicking the down arrow on the unit box. 

 

› [Zoom full] will return the map window to its full zoomed out extent. 

› [Refresh] will update the current view and clear any highlighting. 

› The [SLAM tools] menu as only one option at the current time, which is Search 

Chiefdom Layers. 

The Layers Panel 

The layers panel shows the contents of the map window. A tick ✓ in the box next to the layer 

name means that the map data in that layer appears in the map window. Layers can be 

turned on and off by clicking the cursor inside the tick box. 
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The layers panel is also a legend that reveals how map data are shown. For instance, 

homesteads are shown as a green dot, landholdings as empty green shapes, community 

areas as semi-transparent green areas. 

Where two landholdings overlap, often meaning that both homesteads think they hold the 

same land, the overlapping area is highlighted in semi-transparent red. 

Land rented or borrowed from others is shown with diagonal blue cross-hatched lines, and 

land lent out to others by diagonal orange lines. Note that not all land lent out is shown with 

a corresponding borrowed from, or vice versa. This is because some homesteads have not 

revealed, or they forgotten they borrow in or out some of their land. 

The boundaries layer group shows tinkhundla as areas bounded by blue lines and cadastral 

areas bounded by red lines. All tinkhundla are shown but only the cadastral areas in the 

vicinity of the chiefdom. Cadastral areas include SNL as well as TDL. The Surveyor General’s 

Department have assigned numbers to all cadastral areas, SNL and TDL farms. Therefore, 

the red numbers do not necessarily infer that the cadastral area is a farm. 

The layer called grid which is turned off by default shows all the orthophoto maps available 

at the Surveyor General’s Department. Some of these maps, which cover the chiefdom, are 

included and listed in the image maps group of layers. 
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Status Bar 

The bottom of the QGIS window is called the status bar.  

 

The search box [Type or locate] is not used. The scale box shows the map window scale 

ratio. Magnifier zooms in or out without changing the map scale. EPSG is a code for how the 

map data is shown, and like the other items in the status bar, is not important. 

Finally, in the top right hand corner of the QGIS window are three shapes. These are 

standard to all Microsoft computer programs. Clicking the dash – will minimise the QGIS 

window and place it on the laptop’s desktop status bar (at the bottom of the laptop screen). 

Clicking the  box will maximise the QGIS window to the whole laptop screen. Clicking the  

will close the QGIS software. 
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E.1 Plugin Search Chiefdom Layers 

[Search chiefdom layers] allows landholding attribute text data to be revealed by searching 

for specific text, such as person’s name. 

  

A search box will open. Type the text to search in the [Search For] box. The search can be 

made on all layers, as in the example above, or restricted to specific layers and if a search 

layer is defined [Search in Layer], the search can be more specific to the type of data or 

[Search in Field]. 

Clicking the [Search] button reveals all data records that match the search criteria, and in 

the case above, all records with “Dlamini” in one of the fields of the layer. 

Highlighting (clicking) the a result line in the box will automatically pan and zoom the map 

window to the location of the selected line. If result in layer “Homesteads” is selected, the 

map will pan to the homestead point (dot), which will be highlighted in yellow. If a result in 

layer “Land Holdings” is selected, the map will zoom to the field area, highlighted in yellow. 

The search criteria [Comparison] provides for more detailed searches and results. The 

default option is contains meaning any text that contains the [Search For] text will be found. 

If = is used, the search is much more exact on complete content begin equal to the [Search 

For] text. The third option begins with shows only results where the text begins with these 

characters entered in the [Search For]. 

 


